Difference between revisions of "Installing ChipWhisperer/Required Tools - Mac OS X"

From ChipWhisperer Wiki
Jump to: navigation, search
m
(Change header levels)
 
Line 1: Line 1:
<h2> Python </h2>
+
<h4> Python </h4>
 
The following have been tested on Mac OS X Yosemite (10.10) - earlier versions may not have a recent enough Python installation (recommended 2.7.6 or later). It's possible to install other Python versions on your Mac OS X via the 'homebrew' system, we will use this for installing a few additional required tools.
 
The following have been tested on Mac OS X Yosemite (10.10) - earlier versions may not have a recent enough Python installation (recommended 2.7.6 or later). It's possible to install other Python versions on your Mac OS X via the 'homebrew' system, we will use this for installing a few additional required tools.
  
Line 18: Line 18:
 
$ echo 'import site; site.addsitedir("/usr/local/lib/python2.7/site-packages")' >> /Users/macmini/Library/Python/2.7/lib/python/site-packages/homebrew.pth</pre></li></ol>
 
$ echo 'import site; site.addsitedir("/usr/local/lib/python2.7/site-packages")' >> /Users/macmini/Library/Python/2.7/lib/python/site-packages/homebrew.pth</pre></li></ol>
  
<h2> SciPy </h2>
+
<h4> SciPy </h4>
 
You may need to upgrade your SciPy from the base install if you wish to do template attacks. This is not needed for other attacks, so please only proceed with the following if you receive an error that your version of scipy is too old.
 
You may need to upgrade your SciPy from the base install if you wish to do template attacks. This is not needed for other attacks, so please only proceed with the following if you receive an error that your version of scipy is too old.
  
Line 29: Line 29:
 
  brew link --overwrite numpy
 
  brew link --overwrite numpy
  
<h2> libusb </h2>
+
<h4> libusb </h4>
 
libusb is needed for the ChipWhisperer software to communicate with the board.
 
libusb is needed for the ChipWhisperer software to communicate with the board.
  
Line 36: Line 36:
 
  brew install libusb
 
  brew install libusb
  
<h2> AVR-GCC </h2>
+
<h4> AVR-GCC </h4>
  
 
You can easily use brew to install avr-gcc, as decribed at [https://github.com/osx-cross/homebrew-avr/ OSX-Cross Project]:
 
You can easily use brew to install avr-gcc, as decribed at [https://github.com/osx-cross/homebrew-avr/ OSX-Cross Project]:

Latest revision as of 05:37, 1 May 2018

Python

The following have been tested on Mac OS X Yosemite (10.10) - earlier versions may not have a recent enough Python installation (recommended 2.7.6 or later). It's possible to install other Python versions on your Mac OS X via the 'homebrew' system, we will use this for installing a few additional required tools.

  1. Ensure your user account has a password. In order for the 'sudo' command to work it requires you to type your password, so if you don't have one enabled be sure to set a temporary password now.
  2. Install the 'homebrew' system, see brew.sh for details. Briefly, you can install it by pasting the following in a terminal:

    $ ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
  3. As PySide is based on Qt 4, which is not officially supported by Homebrew, you will need to load the homebrew-qt4 tap:

    $ brew tap cartr/qt4
  4. Install PySide using homebrew:

    $ brew install pyside

    If you recieve an error saying that no such package exists, you can also install PySide using the pip installer

    pip install -U PySide

    The install will probably print a message like this:

    image

    Note you must run that command in order to successfully import the modules, in this example it would be:

    $ mkdir -p /Users/macmini/Library/Python/2.7/lib/python/site-packages
    $ echo 'import site; site.addsitedir("/usr/local/lib/python2.7/site-packages")' >> /Users/macmini/Library/Python/2.7/lib/python/site-packages/homebrew.pth

SciPy

You may need to upgrade your SciPy from the base install if you wish to do template attacks. This is not needed for other attacks, so please only proceed with the following if you receive an error that your version of scipy is too old.

The easiest method is to use brew again:

brew install scipy

You will also need to follow the instructions as above (inserting the link to the brew site-packages location). You will finally need to run the following:

brew link --overwrite numpy

libusb

libusb is needed for the ChipWhisperer software to communicate with the board.

Again, use brew:

brew install libusb

AVR-GCC

You can easily use brew to install avr-gcc, as decribed at OSX-Cross Project:

$ brew tap osx-cross/avr

$ brew install avr-gcc